XF2.1 XenForo in Verbindung mit FontAwesome, GoogleADS und Speed der Mobilen Ansicht.

Dieses Thema im Forum "Informationen, Tipps und Tricks" wurde erstellt von Masetrix, 11. Mai 2020.

  1. Masetrix

    Masetrix Aktives Mitglied Lizenzinhaber

    Nun brauche ich mal wieder die Community um abzuklären ob der folgende Effekt nur hier lokal zu verzeichnen ist oder das auch sonst jemand nachvollziehen kann.

    Wie bekannt wird unser gut besuchtes Forum (...) über GoogleADS finanziert.
    Natürlich habe ich alles unternommen den Anfordrungen von Google bei XenForo genauso gerecht zu werden wie das unter vB3.8.11 der Fall war. Hier, und auch nachfolgend beziehen sich die genannten Werte immer im Hinblick auf die Startseite ohne Adblocker.

    Mit vB erreichte ich seinerzeit in der Desktopansicht gute 92 Punkte, mit einer Modifikation die einen MobileStyle nachrüstete, glatte 100 Punkte.
    Bei XF2.1.x komme ich in der Desktopversion nun auf 98/99 Punke, in der Mobileansicht maximal 82 Gesamtunkte für die Seitenladezeit.
    Letzteres trotz vieler Tests und Optimierungen des Apachen, SQL-Servers und Einsatz von REDIS. Das wurmt und kostet "Plätze" im Ranking bei Google.

    (Keine Sorge, wir kommen zum Ende...)
    Im englischen Forum verfolgte ich nun ein Thema bei dem es um das Optimierte laden von
    FontAwesome geht.

    Hier hatte ich selbst schon das eventuelle doppelt laden der *400".woff unterbunden.
    Nun bin ich jedoch soweit gegangen das laden der Dateien komplett zu unterbinden indem ich den Inhalt (zum späteren wiederherstellen des Templates) zuerst speicherte und danach, den Inhalt löschte und das Script erneut speichert.

    Ich staunte nicht schlecht als die Werte von GooglePagespeed, hernach von bisher 82 Punkten bei der MobilenAnsicht, auf nun 92 Punkte sprangen.
    Natürlich habe ich erstmal alle Caches geleeert, den Apachen, Redis und MySQL auf dem Server neu geladen sowie auch lokal alle Caches geleert um zu Prüfen ob das nicht Laden
    der Daten aus dem Template "font_awesome_setup" Nachteile bringt. Das scheint aber nicht so zu sein - warum auch immer. Alles was ich dachte das es ohne diese Dateien nicht geladen würde (Icon Suche, Registrierung, Node ->Read/Unread ist vorhanden als würden die Dateien geladen.

    Kann das jemand verifizieren?
     
    Zuletzt bearbeitet: 11. Mai 2020
  2. Tealk

    Tealk Bekanntes Mitglied Lizenzinhaber

    Verstehe ich das richtig, du hast die Datei einfach geleert? Oder was genau soll dieses verschachtelte heißen?

    Hast du das für jede einzelne Datei gemacht? Weil es gibt ja die regular, solid und brands
     
    Masetrix gefällt das.
  3. Masetrix

    Masetrix Aktives Mitglied Lizenzinhaber

    Einfach die Datei/das Template: font_awesome_setup geleert und abgespeichert, sodass nun nichts mehr daraus geladen wird.
     
    Zuletzt bearbeitet: 11. Mai 2020
  4. Masetrix

    Masetrix Aktives Mitglied Lizenzinhaber

    Ich bin der Sache - durch Zufall - nun schon etwas näher gekommen.

    Ich habe insgesamt 4 Styles.
    1.) den per extra.less etwas gepimpten Defaultstyle von XenForo 2.1.8, als Standard-Style
    2.) den selben Style als Unterstyle des Standardstyle, nur sind hier die Schriftarten etwas größer.
    3.) einen "Darkstyle", als eigenständigen Style.
    4.) den DefaultStyle von XF als eigenständigen CustomStyle, auch leicht gepimpt.

    Gelöscht habe ich das Template: font_awesome_setup nur im StandardStyle den jeder als Gast im Standard zu sehen bekommt.
    Nun scheint sich XF die Daten, die im Standardtemplate font_awesome_setup gelöscht sind, aus dem Unterstyle abzugreifen, wo das Template noch original ist.
    Scheinbar wurden die Daten zuvor mehrfach geladen was den Ladevorgang im Standard (insbesondere im Mobileview) natürlich merklich verzögert.
    Nur so kann ich mir den Geschwindigkeitzuwachs erklären, selbst das Laden von Themen ( @Kirby hat mir da mal eine Lehre erteilt) ist nun um Längen besser, sodass auch hier nach dem 3ten Laden über 90 Punkte erreicht werden, was zuvor undenkbar war.

    Soweit, sogut, ich hoffe aber dennoch dass da noch jemand ein wenig verifizieren kann,,,
     
    Zuletzt bearbeitet: 12. Mai 2020
  5. Masetrix

    Masetrix Aktives Mitglied Lizenzinhaber

    Auch heute, einen Tag später, nachdem alle Servicefunktionen von XF zumindest einmal durchgelaufen sind, dasselbe Ergebnis, Heute zeigt Pagespeed PageSpeed Insights
    sogar 92 Punkte bei der mobilen Startseite,
    upload_2020-5-12_7-24-9.png

    Desktop...
    upload_2020-5-12_7-25-35.png
     
  6. Hoffi

    Hoffi !important Lizenzinhaber

    Eigentlich eher aus dem Masterstyle. Das System geht den Weg nach Oben, nicht nach unten.
     
    Masetrix und otto gefällt das.
  7. Masetrix

    Masetrix Aktives Mitglied Lizenzinhaber

    Ja, das habe ich inzwischen auch realisiert. :)
    Inzwischen lade ich in der "core_fa.less" auch nur noch die .woff Dateien fürs "Branding" und die Standardsymbole (400/.farEGULAR) .
    Code (Text):

    @font-face {
      font-family: 'Font Awesome 5 Pro';
      font-style: normal;
      font-weight: 400;
       font-display: swap;
     src: url('@{fa-font-path}/fa-regular-400.woff2?_v=@{fa-version}') format('woff2'),
        url('@{fa-font-path}/fa-regular-400.woff?_v=@{fa-version}') format('woff');
    }
    .far {
      font-family: 'Font Awesome 5 Pro';
      position: relative;
      font-weight: 400;
       font-display: swap;
    }
    @font-face {
      font-family: 'Font Awesome 5 Brands';
      font-style: normal;
      font-weight: 400;
      font-display: swap;
      src: url('@{fa-font-path}/fa-brands-400.woff2?_v=@{fa-version}') format('woff2'),
        url('@{fa-font-path}/fa-brands-400.woff?_v=@{fa-version}') format('woff');
    }
     
    dazu habe ich noch hier und da ein " font-display: swap;" hinzugefügt sodass Google wegen den "zu spät geladenen" Schriftarten nicht mehr mosert und auch der Score des MobileStyle zwischen 90 und 94 pendelt. Den Rest an "url('@{fa-font-path...", weiter unten in der Datei habe ich auskommentiert sodass dort kein laden mehr erfolgt.

    Auch hat Google seine Seite, nach dem MaiUpdate, schon wieder geändert...

    upload_2020-6-5_13-30-37.png
    upload_2020-6-5_13-31-26.png
    upload_2020-6-5_13-32-38.png
    ....

    Nun bin ich soweit zufrieden nachdem das Problem, dass der MobileStyle soviel weniger "Scored" wie der Desktopstyle, endlich behoben ist . Leider werden mit XF 2.2 ja die nächsten "BonBons" auf mich/uns warten - wenn ich die Ankündigungen richtig verstehe/interpretiere. :/
     
    Zuletzt bearbeitet: 5. Juni 2020 um 13:36 Uhr
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden